Idle to high

MGB discussion board for Roadster and GT classic car models.
Post Reply
Cruisinforicecream
Posts: 4
Joined: Tue Oct 08, 2013 11:04 pm

Idle to high

Post by Cruisinforicecream » Tue Oct 07, 2014 10:32 am

Fired up lovely after getting my engine back together, and doin my my best to set the carbs, she seems to run spot on, drives & pulls well, though idling to high, turn down the revs with the screws on the carbs, but they can come all the way out, not even touching the little flange they lean on, but still the revs are are too.
Thing is, my tach isn't working at the minute (workin' on it), but even without it, I can hear I'm ticking over somewhere between 1200 - 1400

What's goin' on ?

User avatar
jonahnaylor
Posts: 47
Joined: Mon Oct 07, 2013 10:35 pm
Location: York, United Kingdom
Contact:

Re: Idle to high

Post by jonahnaylor » Tue Oct 07, 2014 3:44 pm

Hi have you set the timing correctly to the workshop book, I found with mine that there are quite a few different settings other than 10 degrees tdc depending on Engine number etc. Also it may be to do with your Vacuum advance at idle, which could be why the car is ok when moving and the advance changes...

I'm just speculating here though, what else have you tried? Have you set the mixture etc correctly too?
--
Yorkshire website design, domain registrations & hosting:
https://www.yorkshire.hosting

Post Reply

Return to “MGB Roadster & MGB GT Forum”

Who is online

Users browsing this forum: No registered users and 2 guests